EMEA Nodes - Delayed Data

Incident Report for Catchpoint Systems Services Page

Monitoring

A fix has been implemented, and the affected data has been successfully backfilled. We will continue to closely monitor the services to ensure ongoing stability.
Posted Sep 12, 2026 - 05:56 EDT

Investigating

We are currently investigating an issue affecting nodes in the EMEA region. The issue began at approximately 02:45 UTC on September 12, 2026.
Our team is actively investigating the issue. We will provide additional updates as more information becomes available.
Posted Sep 12, 2026 - 05:02 EDT