Datacenter Maintenance - Saturday, September 27th from 11:00 to 14:00 ET

Scheduled for Sep 27, 11:00 - 14:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 09, 2025 - 14:44 EDT

Scheduled

Catchpoint will be performing datacenter maintenance on Saturday, September 27th from 11:00 to 14:00 ET

There will be several short periods of delayed test data during the maintenance window.

Please contact us at support@catchpoint.com if you have any questions.
Posted Sep 27, 2025 - 11:00 EDT