Partial Unavailability of EMEA Historical Capture Data

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 08:59 EST

Investigating

A subset of historical capture data (Headers, Response content, Filmstrips and Screenshots) in the EMEA region is currently unavailable. The real time data remains fully operational and unaffected.
We are actively working to restore the impacted historical data.
Posted Nov 05, 2025 - 14:47 EST