Portal Content Not Displaying

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 01:43 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 12, 2025 - 01:33 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 12, 2025 - 01:17 EST

Investigating

We are currently investigating an issue impacting the catchpoint portal. Some users may experience a blank page after logging in or when attempting to view records.

Please note that tests and alerts continue to function as expected. Our team is actively working to resolve this as quickly as possible.
Posted Dec 12, 2025 - 01:03 EST
This incident affected: Portal.