Issue Affecting a Subset of Cloud Nodes

Incident Report for Catchpoint Systems Services Page

Resolved

We have resolved an issue that affected a subset of Cloud nodes between 07:49 AM UTC and 10:04 AM UTC.

During this time, tests targeting these affected nodes may have experienced degraded performance or missing runs.

Portland, US - AWS Cloud
Los Angeles, US - Akamai CC
Denver, US - AWS Cloud
Arizona, US - Azure Cloud
Phoenix, US - Oracle Cloud
San Jose, US - Oracle Cloud
San Jose, US - Alibaba Cloud
Los Angeles, US - AWS Cloud
Seattle, US - Akamai CC
Fremont, US - Akamai CC
Fresno, US - Azure Cloud
San Francisco, US - Tencent Cloud
Las Vegas, US - Google Cloud
Portland, US - Google Cloud
Los Angeles, US - Google Cloud

All systems are now operating normally!
Posted Nov 13, 2025 - 06:58 EST