Portal Slowness Impacting Test Properties

Incident Report for Catchpoint Systems Services Page

Resolved

We have resolved the issue that caused slowness within the portal, where users may have experienced delays while performing actions on the test properties blade.

The incident was traced to a third-party service used by the portal. We have temporarily stopped the functionality that relies on this service while we work with the provider to determine why it caused the issue and to prevent recurrence.

If you need additional details please reach out to support@catchpoint.com
Posted Nov 19, 2025 - 10:59 EST

Investigating

We are currently investigating slowness in the portal. Users may experience delays when performing actions on the Test Properties blade.

Our team is actively investigating the issue to restore normal performance as quickly as possible.
Posted Nov 19, 2025 - 10:30 EST
This incident affected: Portal.