Increased ISP Incident Reports in Internet Sonar

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 20:42 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 11, 2025 - 16:24 EST

Investigating

We are currently investigating an increase in reported ISP-related incidents in Internet Sonar. Further updates will be shared as soon as more information is available.
Posted Dec 11, 2025 - 15:53 EST
This incident affected: Application Data.