Issue affecting SSL tests

Incident Report for Catchpoint Systems Services Page

Resolved

We identified and resolved an issue affecting SSL tests running on the US East Backbone and Cloud nodes from August 14, 2026, at 10:28:00 UTC to 13:14:10 UTC.
Posted Aug 14, 2026 - 09:44 EDT