Service Disruption Notice – Email Support

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 10:15 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2026 - 08:11 EDT

Investigating

We are currently experiencing an issue with our email support channel, which may impact our ability to receive or respond to emails in a timely manner.

In the meantime, we request you to reach out to us using Live Chat or by opening a ticket through the Resource Center in the portal for faster assistance.

Our team is actively working to resolve this issue and will provide updates as soon as more information becomes available.
We appreciate your patience and understanding.
Posted Apr 15, 2026 - 07:01 EDT
This incident affected: Catchpoint Help Center.